So you have an email step in one of your workflows which is set to go out automatically. But for some reason, a new lead comes in and the email doesn't go out. This can happen for a number of different reasons.

Troubleshooting: Option 1

In most cases you can always find out why an email didn't send automatically to a given lead by following these steps.

  1. Go to the page of the lead in question by clicking their link on the lead table.
  2. Look at the tasks in the center of the page (see screenshot).

3. You should see an email task which is highlighted red.
4. To view the error that prevented the email to send automatically, simply hover your mouse over the red, email icon on the task. 

In the case of this email, it didn't send because this lead unsubscribed from our automatic emails. 

Depending on the case, you may get a variety of error messages, some of which may be a little confusing. If you encounter an error message you don't understand, email us at support@leadsimple.com and we'll help explain the issue to you and get it fixed.

Troubleshooting: Option 2

If the email task is not colored red, this indicates that the email didn't send out for a different reason (not because of an error, in other words). This most often happens for manually added leads.

NOTE: LeadSimple will only send automatic emails to auto-imported leads, not manually-created ones. This prevents the possibility of sending a duplicate or irrelevant email to a lead you've already communicated with. 

In light of that, check the bottom of the activity feed of a lead's record to confirm if the lead was imported automatically or created manually. 

Did this answer your question?